Очередной "мягкий" отключатель активных и не очень пользователей

Публикация № 1154117

Администрирование - Информационная безопасность - Роли и права

Расширение пример

4
Тема отключения пользователей не нова, но это чуть другой взгляд на проблему.

Поставлено ТЗ написания как можно более простого метода, чтобы "мягко" отключать пользователей. Базы как клиент-серверные, так и файловые. И отключать надо по команде, а не каждую сессию отдельно руками.
Концепция решения "мягкого" отключения следующая - пользователь должен "сам" завершить свою работу. Иными словами необходимо дать клиенту понять, что необходимо завершить работу. Вариаций можно добавить сколько угодно.

Для этого была написана админовская часть, использующая некую табличную часть сеансов, получающая сеансы с АГЕНТА для клиент-серверных баз, так и  с файловых баз, используя механизм COM(медленный) или HTTP-сервисы(быстрый, предпочтительно), с функцией отключения нужного сеанса:

Процедура ДатьЗаданиеНаОтключениеСеансовИБ(ИБ, ИмяПользователя, НомерСеанса, ИмяПриложения, Компьютер, СообщениеПользователю = "", ТаймАут=10) Экспорт
	// Сеанс.ИмяПриложения
	//1CV8 - идентификатор приложения 1С:Предприятие в режиме запуска "Толстый клиент"; 
	//1CV8C - идентификатор приложения 1С:Предприятие в режиме запуска "Тонкий клиент"; 
	//WebClient - идентификатор приложения 1С:Предприятие в режиме запуска "Веб-клиент"; 
	//Designer - идентификатор приложения Конфигуратор; 
	//COMConnection - идентификатор сессии внешнего соединения 1С:Предприятия через COM; 
	//WSConnection - идентификатор сессии Web-сервиса; 
	//BackgroundJob - идентификатор сессии обработки заданий; 
	//SystemBackgroundJob - идентификатор системного фонового задания; 
	//SrvrConsole - идентификатор сессии консоли кластера; 
	//COMConsole - идентификатор административной сессии внешнего соединения; 
	//JobScheduler - идентификатор сессии планировщика заданий; 
	//Debugger - идентификатор сессии отладчика; 
	//OpenIDProvider - провайдер OpenID; 
	//RAS - идентификатор сервера администрирования.

	Если ИмяПриложения = "1CV8" или ИмяПриложения = "1CV8C" или ИмяПриложения = "WebClient" или ИмяПриложения = "Толстый клиент" или ИмяПриложения = "Тонкий клиент" или ИмяПриложения = "Веб-клиент" Тогда
		КлючОбъекта			= "ЗавершениеРаботы";
		КлючНастроек		= СтрЗаменить(Строка(НомерСеанса), Символы.НПП,"");
		Настройки			= ИБ.NewObject("Структура");
			Настройки.Вставить("Пользователь",				ИмяПользователя);
			Настройки.Вставить("ТекущийПользователь",		ПараметрыСеанса.ТекущийПользователь.Наименование);
			Настройки.Вставить("Компьютер",					Компьютер);
			Настройки.Вставить("Сеанс",						НомерСеанса);
			Настройки.Вставить("ДатаИнициацииОтключения",	ТекущаяДата());
			Настройки.Вставить("ТаймАут",					ТаймАут);
			Если НЕ СообщениеПользователю = "" тогда
				Настройки.Вставить("РежимОтключения",		2);// 0 - отключение без предупреждения, 1 - вывести с предупреждением , 2 - просто сообщение
				Настройки.Вставить("СообщениеПользователю",	СообщениеПользователю);
			Иначе
				Настройки.Вставить("РежимОтключения",		1);// 0 - отключение без предупреждения, 1 - вывести с предупреждением
				Настройки.Вставить("СообщениеПользователю",	"Сообщение от Админа: ""Просьба выйти из базы для выполнения архивации""");
			КонецЕсли;
		ОписаниеНастроек 	= "Отключение пользователя по запросу администратора";
		ИБ.ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, КлючНастроек, Настройки, ОписаниеНастроек, ИмяПользователя);
	КонецЕсли;
КонецПроцедуры

Поскольку почти все клиентские базы стоят на поддержке без возможности вносить изменения, то было написано расширение. В нем присутствует функция оценки задания на отключение. Отключается только необходимый пользователь. По сути дела, решение принимает клиентская часть - "Если МНЕ задание на завершение работы, то будет предпринята попытка отключения". Ниже сама функция отключения

Функция КонтрольЗавершенияРаботы() Экспорт
	НомерСеанса 		= ЗРП_ОбщийМодульСервер.ПолучитьНомерСеанса();
	НачалоРаботы		= ЗРП_ОбщийМодульСервер.ПолучитьдатуСеанса(НомерСеанса);
	СтруктураПараметров = ЗРП_ОбщийМодульСервер.ЗагрузитьХранилищеОбщихНастроек("ЗавершениеРаботы", СтрЗаменить(Строка(НомерСеанса),Символы.НПП,""), ИмяПользователя());
	Если НЕ СтруктураПараметров = Неопределено Тогда
		Если НЕ ЗРП_ОбщийМодульСервер.ЗапущенКонфигуратор() Тогда
			Если НомерСеанса = СтруктураПараметров.Сеанс Тогда
				ЗРП_ОбщийМодульСервер.УдалитьХранилищеОбщихНастроек("ЗавершениеРаботы", СтрЗаменить(Строка(НомерСеанса),Символы.НПП,""), ИмяПользователя());
				Попытка
					Если СтруктураПараметров.ДатаИнициацииОтключения > НачалоРаботы Тогда  // если пользователь успел выйти до команды
						Если СтруктураПараметров.РежимОтключения = 0 Тогда  // безусловное завершение без вопросов
							ЗавершитьРаботуСистемы(Ложь);
						ИначеЕсли СтруктураПараметров.РежимОтключения = 1 Тогда // только сообщение с описанием того кто выдал задание на закрытие
							Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияПредупреждения", ЗРП_ОбщийМодульКлиент);
							ПоказатьПредупреждение(Оповещение, СтрЗаменить(СтруктураПараметров.СообщениеПользователю, "%", СтруктураПараметров.ТекущийПользователь), СтруктураПараметров.ТаймАут);
						ИначеЕсли СтруктураПараметров.РежимОтключения = 2 Тогда // выдача вопроса с интерактивным выбором ЗАКРЫТЬ или НЕТ
							Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЗРП_ОбщийМодульКлиент);
							Кнопки = Новый СписокЗначений;
							Кнопки.Добавить(КодВозвратаДиалога.ОК, "Завершить");
							Кнопки.Добавить(КодВозвратаДиалога.Отмена, "Отмена");
							ПоказатьВопрос(Оповещение, СтрЗаменить(СтруктураПараметров.СообщениеПользователю, "%", СтруктураПараметров.ТекущийПользователь), Кнопки, СтруктураПараметров.ТаймАут, , "Завершение работы системы");
						ИначеЕсли СтруктураПараметров.РежимОтключения = 3 Тогда // только сообщение
							Предупреждение(СтруктураПараметров.СообщениеПользователю, СтруктураПараметров.ТаймАут);
						КонецЕсли;
					КонецЕсли;
				Исключение
					ЗРП_ОбщийМодульСервер.ЗЖР("ЗавершениеРаботыПользователей.КонтрольЗавершенияРаботы()", "Ошибка",,ОписаниеОшибки());
				КонецПопытки;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли; 
КонецФункции 

Расширение на данный момент работоспособно на версии ЗУП 3.1.11.133, БУХ 3.0.73.60, КА2 2.4.7.141/3.2.23.3(БИТфинанс). Поскольку не использовалось БСП, то и проблем с библиотекой тоже нет.
Остались две проблемы:

1. Разрешимая - условие совместимости, меняемое при обновлении, которое можно исправить в любой момент;
2. Не решённая - если на главном окне вылезло окно с вопросом, блокирующим весь интерфейс, ожидающего интерактивного принятия решения. Поиск решения ведётся.

 

P.S. Сильно прошу палками не кидать. Любые реальные ссылки будут восприняты с благодарностью.

4

Скачать файлы

Наименование Файл Версия Размер
ЗавершениеРаботыПользователей_ТАКСИ_009.cfe
.cfe 9,50Kb
15.11.19
2
.cfe 191024.009 9,50Kb 2 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Xershi 759 15.11.19 19:15 Сейчас в теме
Какое может быть решение, когда пользователь ушел домой. Только рубить.
А какая цель публикации, академический интерес?
По поводу расширения. Пишут обработку и она анализирует совместимость и затем ставит нужную версию.
2. ybatiaev 50 16.11.19 00:03 Сейчас в теме
(1) Если необходимо АВТОМАТИЧЕСКИ обновить базы, без участия программистов, но:
- база файловая(как можно рубить программно? Научите);
- необходимо обновить около 500 баз за ночь и ничто не должно помешать;
- необходимо отключать только те базы, в которых не работают в конфигураторе или отключить по определённому правилу .

Цель публикации - поделиться опытом.

По поводу обработки напишите путь решения. Буду признателен. Кроме интерфейса только "Такси" или "Такси. Разрешено..," есть ещё и совместимость версий.
zabaluev; +1 Ответить
3. Xershi 759 16.11.19 09:48 Сейчас в теме
(2) для примера посмотрите как сейчас ставится Битрикс.

На файловой базе запуск обработки блокировки пользователей, как и в клиент серверной.
Про 500 баз. Так у вас же расширение, а не конфигурация для обновления.
4. ybatiaev 50 17.11.19 01:15 Сейчас в теме
(3) про битрикс не понял. В смысле как ставится? Хочу с ним познакомится, но руки не доходят.
Не понял и про блокировки. К чему Вы это написали? И я про блокировку не писал (моя конфа и это делает при необходимости).
Про 500 баз - данное расширение помогает выкинуть пользователей без участия программиста... у меня в том числе и конфигурация обновлений.
5. dock 35 18.11.19 08:59 Сейчас в теме
1) в ЗУП3 и БУХ3 прекрасно отрабатывает и типовой механизм... (в том числе и для файловых баз).
2) На скрине очень интересное сообщение от админа: "... для выполнения архивации"
В серверных базах архивация (бекап) выполняется средствами SQL, в файловых базах - специальными утилитами (например cobian backup), посредством теневой копии. В обоих случаях, выгонять пользователей не требуется :).
6. ybatiaev 50 18.11.19 14:43 Сейчас в теме
(5)
- "Смешное сообщение" - сделал для теста. Задаётся любое в админовской части.
- У нас сисадмины отделены от программеров вообще и средствами SQL делается всё с разрезом неделя. Всего неделя. Главная их задача - бесперебойная работа СУБД, скорость и оперативность исправления ошибок;
- с базами работают и пользователи-администраторы. Других не дёргают. Хранение баз (любой базы) настраиваемое. Без администраторов баз сами базы могут быть восстановлены или сделан срез перед операциями. Таких срезов много и дергать администраторов не разрешают;
- Восстановление из бакапа SQL процесс более затратный по времени, чем из DT;
- файловую базы можно просто скопировать, если что, но обновить после этого всё же не удастся, если база залочена. Прошу подсказать типовой программный механизм с файловыми базами, без участия программиста пожалуйста. Направьте, может что упустил. Работы много... всего читать не успеваю.
7. dock 35 18.11.19 15:06 Сейчас в теме
(6)
1)
- Восстановление из бакапа SQL процесс более затратный по времени, чем из DT;

Если загрузка из DT происходит быстрее, чем загрузка из бекапа SQL.... значит у вас что-то не так с SQL базой :) однозначно!
Чисто технически, при загрузке из DT, выполняется больше операций :)
2)
- файловую базы можно просто скопировать, если что, но обновить после этого всё же не удастся, если база залочена.

просто скопировать, если в базе "сидит" хотя бы один пользователь ? ни разу не получалось "просто скопировать" :)
про "залочена" не понял... залочена средствами 1С или системой ?
8. ybatiaev 50 19.11.19 08:03 Сейчас в теме
(7) по 1 вопросу - передам сисадминам. Насколько мне известно восстановление с DT "чистит" пустое место и частично восстанавливает "битые" ссылки, если это возможно. С SQL восстанавливается ВСЁ полностью. Поэтому операций да, больше.
по 2 пункту - да прям. Сейчас проверил, может что изменилось. Открыл и конфигуратор и клиента. *.1CD прекрасно скопировался. И это является стандартным механизмом "бакапа" при автообновления у самих 1С-ников.
9. dock 35 19.11.19 11:21 Сейчас в теме
(8)
*.1CD прекрасно скопировался.

соглашусь, я не прав... Но это уже изменение на уровне самой платформы - раньше была ошибка "файл занят"...
Всё течёт, все меняется :)
Оставьте свое сообщение

См. также

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы) 4

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    501    2    Diana.dedov.91    0       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.10.х и УТ 11.4.10.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Менеджер подключений к удаленным рабочим столам (RDP) 8

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) Роли и права

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    1070    2    Shalnov    1       

Изменение запрета редактирования в дереве по группам пользователей 0

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::Права УПП1 Россия Абонемент ($m) Роли и права

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    544    trest30    0       

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

Анализ прав пользователей 2

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 ERP2 Россия Абонемент ($m) Роли и права

Отображает права по ролям и пользователям на конкретный объект конфигурации.

1 стартмани

13.11.2019    857    1    linder    2       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Анализ прав доступа 2

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m) Роли и права

Отчет по правам доступа, который позволяет выбрать объект метаданных и проанализировать, какие роли дают права на объект.

1 стартмани

08.11.2019    1500    5    Unk92    13       

Запуск внешних обработок по списку пользователей 0

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 БП3.0 Абонемент ($m) Роли и права

Создает командный файл для запуска пользователей по списку.

1 стартмани

07.11.2019    943    Mari_Kuznetzova    0       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Блокировка учетных записей пользователей, кроме "Администратор" 0

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Роли и права

Обработка блокирует все учетные записи, кроме учетной записи именуемой - "Администратор".

3 стартмани

04.11.2019    881    2    Alex1053669    0       

Установка даты запрета на любое число дней 5

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ11 Абонемент ($m) Администрирование данных 1С Роли и права

Примитивная обработка для установки даты запрета на произвольное число дней от текущей даты для всех пользователей

1 стартмани

29.10.2019    1299    2    Kutuzov    0       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Быстрое удаление ролей из профилей групп доступа. 6

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права Абонемент ($m) Роли и права

Обработка позволяет найти все профили групп доступа по роли, понять для каких групп доступа и пользователей доступна эта роль, удалить роль из выбранных профилей.

1 стартмани

23.10.2019    1124    1    igoSolo    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Копирование дополнительных прав, групп доступа между пользователями/группами [1С:Розница] 1

Инструменты и обработки no Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Абонемент ($m) Роли и права

Копирование, сравнение и редактирование дополнительных прав пользователей. Включение пользователя-приемника в те же группы доступа, в которых участвует пользователь-источник.

1 стартмани

21.10.2019    1205    1    RocKeR_13    0       

Расширение для установки запрета редактирования отдельных справочников и документов для Бухгалтерии 3.0 2

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права БП3.0 Россия БУ Абонемент ($m) Расширения Роли и права

Расширение позволяет устанавливать запрет на редактирование отдельного справочника или отдельного документа для отдельного пользователя базы данных. Написано для Бухгалтерии 3.0, проверено на релизе 3.0.72.70 и платформе 8.3.14.1854. Работает после применения ограничений профиля пользователя. Ограничивает даже права профиля с полными правами в открытом периоде.

1 стартмани

17.10.2019    1383    e-tixom    2       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

RLS - дубли условий в запросах к СУБД 39

Статья Программист Конфигурация (md, cf) v8 v8::Права 1cv8.cf Абонемент ($m) Практика программирования Роли и права

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    3564    8    geron4    4       

Завершение работы пользователей 18

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Завершение работы пользователей с помощью подключения обработчика ожидания.

1 стартмани

02.10.2019    2202    3    user921814    6       

Многофункциональная выгрузка из 1С: Управление торговлей (УТ11, УТ10) в Бухгалтерию предприятия (БП2, БП3) Промо

Хотите точно знать, что вы выгружаете? Хотите сворачивать товары по НДС или фильтровать товары по доп. реквизиту? Вы волшебник, которому необходимо превращать одних контрагентов в других? Хотите при выгрузке превратить группу товаров в один? Или просто нужен удобный OLE обмен между 1C Управление торговлей (ред. 11 или 10) и 1С Бухгалтерия предприятия (ред. 2 или 3). Тогда эта обработка для вас!

9500 руб.

Сравнение прав пользователей 11

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Иногда требуется понять, почему какому-то пользователю не доступны какие-либо объекты или действия, а "вручную" сравнивать довольно утомительное занятие.

1 стартмани

23.09.2019    2259    8    ivnik    3       

Оптимизация прав ролей 17

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права 1cv8.cf Россия Windows Абонемент ($m) Производительность и оптимизация (HighLoad) Роли и права

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    3002    2    toxilamer    11       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Расширение "Туманность" - помощник настройки профилей групп доступа. ERP 2.4.9+ 7

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права ERP2 Абонемент ($m) Роли и права

Расширение позволяет настраивать профили групп доступа как комбинации из других профилей групп доступа.

1 стартмани

30.08.2019    1402    2    Brawler    0       

Расширение для БП 3. Роль "Покупки" 0

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 БУ Оптовая торговля Учет ТМЦ Абонемент ($m) Информационная безопасность

Дополнительная роль "Покупки" менеджеру по продажам для Бухгалтерии предприятия 3. Типовые права предусматривают только роль "Менеджер по продажам".

1 стартмани

23.08.2019    1478    4    Akuji    0       

1С:Предприятие через Интернет. 1С:Fresh Промо

Ведение бухгалтерского и налогового учет, сдача отчетности, управление бизнесом из любой точки мира. Привычные программы «1С» через Интернет без приобретения коробочных программ.

Ограничение прав пользователя на изменение типов объектов конфигурации при помощи расширения 2

Инструменты и обработки Системный администратор Расширение (cfe) v8 v8::Права БП3.0 Абонемент ($m) Роли и права

Расширение позволяет ограничивать права пользователя на изменение типов объектов конфигурации при наличии прав, заданных профилями групп доступа.

1 стартмани

06.08.2019    1470    its_33    0       

Перенос данных БП 2.0 => УТ 11 / КА 2 / ERP 2 (перенос остатков, документов и справочников из "1С:Бухгалтерия предприятия 8", ред. 2.0 в "1С:Управление торговлей 8", ред.11 / КА 2 / ERP 2). Обновлено до УТ 11.4.10.х, КА 2.4.10.х, ERP 2.4.10.х! Промо

Перенос позволяет загрузить в УТ 11 / КА 2 / ERP 2 документы за выбранный период, справочную информацию и остатки по счетам бух. учета. Переносятся остатки денежных средств, взаиморасчетов, остатки товаров и материалов на складах. Переносятся девятнадцать основных видов документов за выбранный период и вся нормативно-справочная информация. Есть фильтр по организации. Если нужно переносить что-то дополнительно, то обычно бесплатно дорабатываю правила (перед покупкой согласуйте необходимые доработки).

29700 руб.

Анализ ролей пользователей БСП 6

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8::Права 1cv8.cf Абонемент ($m) БСП (Библиотека стандартных подсистем) Роли и права

Внешний отчет для анализ настройки Ролей / Профилей / Групп доступа пользователей 1С. Отчет работает с конфигурациями написанными на БСП версии 2.1 и выше.

1 стартмани

20.07.2019    2200    15    leoxz    0       

Сравнение доступа профилей, ролей, пользователей по всем объектам конфигурации 8.3, 8.2 (обычные формы "ОФ" и управляемые формы "УФ") (выборочно) 11

Отчеты и формы Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m) Роли и права

Сравнение профилей доступа по всем объектам конфигурации 8.3 (полноценно функционирует с версии 1С:Предприятия 8.1.10 - 8.3.X). Очень хотелось иметь обработку, которая бы показывала различия профилей доступа по каждому конкретному объекту конфигурации и по всем сразу. Желание было воплощено в данной обработке.

1 стартмани

23.06.2019    2435    12    AlexandrSmith    0       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

[1С: БП 3] Роль "Кладовщик" 7

Инструменты и обработки Системный администратор Программист Бухгалтер Расширение (cfe) v8 v8::БУ v8::Права БП3.0 Россия БУ Учет ТМЦ Абонемент ($m) Роли и права

Расширение, которое позволяет использовать роль "Кладовщик" для инвентаризации, оприходования и списания товаров.

1 стартмани

21.05.2019    3137    38    dima21m    30       

Права доступа на объект метаданных v.3+ (Реквизиты, Объекты Роли) 5

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 ERP2 УТ11 КА2 ЗУП3.x Абонемент ($m) Роли и права

Доработанная обработка Права доступа на объект метаданных v.3 (Реквизиты, Объекты роли).

1 стартмани

12.05.2019    2226    13    1serger    0